Keyfob does not affect roof (ND1 RF, Europe)

  • Hi,

    Today I installed DRL, ACC/IG and Roof Controller in that order and verified that each install worked as intended before proceeding to the next install.

    I am unable to get my keyfob to open or close the roof with three lock clicks as setup in the software.

    Single click of the open roof button works fine, but keyfob does nothing except lock/unlock the car.

    Anyone had this and if so how did you resolve it?


    Thanks in advance.


  • Are you sure you have IG/ACC module, not ACCPC? I don't have a record that you got it from our store.

    ACCPC has 6 pin connector on the board

    IGACC - 8-pin connector on the board.

  • Fairly sure. Order 8371

  • No you are correct, I have bought the wrong thing! Oh no

  • Wait.. there is no module for the RF, only power controller.

  • Update: Sergey has been incredibly fast with his response and is helping me work this out.

    Apparently I have bougth the correct product after all but made some installation error that I'm working on resolving.

    Thank you Sergey, and apologies for the confusion.

  • Update 2: everything is working as it should after cycling the roof a few times!

    Thanks again Sergey!

  • Can you run me though what you did, having the exact same problem!

  • Hi Rob,

    I fully opened and closed the roof 4 times by manually "clicking" the open/close button.
    After the fourth time the keyfob worked as intended.

  • Tried it but sadly nothing at the moment, emailed for some more help. 


    Clicks do nothing apart from lock/unlock

  • Did you check if all the associated modules work on their own?
    The IG/ACC should enable the entertainment system to stay on after the engine is turned off.
    The roof controller should enable 1-click open/close of roof.

    Did you sync the keyfob using the instructions in the roof controller manual (with the open roof button)?

  • Thanks for taking the time to help!


    The IG/ACC keeps the radio on, and the roof controller works for one touch.


    Can seem to find the sync intructions though? That might be the issue? 

  • It might be a completely useless thing to do, but I started fiddling anyway.

    Page 9 of the RFC2 manual (

    To quickly change the configuration from one-touch to OEM mode or Valet mode use this sequence:
    1. Turn the car power off.
    2. Keep driver side door open.
    3. Enable the programmed one-touch operation for a key fob: Push roof switch up and hold it in
    position. Click the “Unlock” button on the key fob twice. Release the roof switch.
    4. Disable the programmed one-touch operation for a key fob: Push roof switch down and hold it in
    position. Click the “Unlock” button on the key fob twice. Release the roof switch

    I did steps 1-3.

  • Forgot to add;

    AFTER steps 1-3 above, I did the open/close with roof button 4 times that I mentioned earlier and after that I *think* I turned off the car completely for about 15 minutes while leaving the area so they keyfob wasnt around and when I came back the keyfob worked.

  • @Rob Magee Any luck with the steps above?

  • Looks like there is a problem with the CAN messages being differnt in the UK. Sergey is goin to have a look at the messages my car is generating remotly and see if we can get it working.


    Thanks for your suggestions, il let you know if we get somewhere!

  • I see, I love how responsive Sergey is!

    I'm now regretting not getting the window controller so that will be the next purchase :)

    Thanks Rob, I hope it works out. Good luck and happy holidays!

Please login to reply this topic!