Roof Controller Troubleshooting

  • Hello. I have been having issues with my roof controller on my MX-5 RF. I have tried disconnecting the battery with the top and windows down, left disconnected for over 30 minutes and it still gives me a malfunction error. Anyone have an idea as to what the issue might be? When I plug in the roof controller, it closes the top with no problems with just one touch, but when I try to open the top, it gives me the error. I even had MX5things send me a new controller and harness and both are having the same problems. I made sure the connections were in tight.

  • Could you check how it behaves in OEM mode?

  • It works just fine without the Roof controller installed. Just have to hold down the button until it completes operation.

  • @Joseph Shin it is not what I asked. Could you configure the RFC module to OEM mode (using configuration software ) and check how it behaves during closing and opening.

  • oh sure i'll try that tonight and get back to you.

  • Just to verify, you mean set it to one touch disable (OEM limits) for both and have the remote function set to disabled right?

  • @Joseph Shin correct

  • Even with OEM settings, I get a malfunction error. 

  • Hello,


    I tried installing the roof controller too. But when it's connected I get retractable roof malfunction.

    Please help!

  • Hey everyone.  I installed my roof mod yesterday and everything seemed to work well.  I drove my MX5 for about 20 minutes to a car electronic place to ask questions about another mod not working and when I got back into my car, I got a retractable rood malfunction error as well.  I'm hoping it's a loose conection.

  • I double checked and it's not a loose connection.  Very strange how it worked for a little while but then stopped.

  • Hi,

    I also tried installing the RF roof controller yesterday but got the "roof malfunction" message.

    First try it didn't react to the interior toggle switch, and after having checked connections and trying again it still gave me the message but also beeped at me when trying the interior switch.

    I also have the ACC controller installed but it didn't react to the keyfob either. 

    (I bought the kit from as I live in the EU) 

  • Hello, any one solve this issue? i have ordered the roof controller for NC. experiencing the same issues.

  • @Joseph Shin any update sir?

Please login to reply this topic!