Key fob not working with ACC/IG & Roof Controller

  • I installed the ACC/IG module & Roof Controller module. I noticed that the radio stays on after turning off the engine, so it appears the ACC/IG unit works. The Roof Controller- one touch system works when I use the interior roof toggle, but when I go to use the Key Fob to lock/close the roof & unlock/open the roof,  it doesn't respond. I've replaced both units twice and still doesn't function with the key fob. Hmmm?

  • @mx5things   I found the issue with my question above. Key fob #1 works! Key fob #2 doesn't work.
    New question: Why doesn't Key fob #2 work? I programmed them excatly the same in the dashboard (Version 1.2).

  • @CARLOS MARTINEZ This is still a mystery. I have one more customer with the same issue. I can only speculate that it produces a different CAN message, which I'm not aware yet.

    For programming, it is essential to start with the roof down.  To reset everything, first, disconnect the battery for 5 minutes. Reconnect battery. One-click Unlock. Using the internal switch, raise and open the roof again. Only after this try to lock with double(triple clicks)

  • @mx5things  I'll give it a try and see if key fob #2 works. I'll keep you posted. 

  • 2019 RF 30th AV

    Installed ACC/IG + RC + Automatic Roll-Up Windows Controller with key fob support.

    Radio stays on after turning off car / turns off when door opened.

    Windows roll up with a single pull on the driver-side inside controls.

    Roof goes up/down with a single click on the inside controls.

    Now, here's what doesn't work and is now malfunctioning:

    Key fob does nothing to control either windows or roof.

    Key fob now shows low battery and no longer functions unless held against start/stop button.


    Have replaced batteries

    Have tried both fobs.

    Going to try and reset everything by disconnecting battery again for 5 minutes and see if anything changes.

    Definitely not the results I was hoping for!

    @MX5things - if you know of any other tricks to try, please share.  I'm really hoping I don't have to pull all of this stuff out of the vehicle again.  Working on this thing is about as fun as bathing in lemon juice with thousands of fresh cuts on your body...

  • It means that one of the black wires (ACC/IG cable) has bad contact, jammed pin, or pushed out. Black wires are just straight connections from one connector to another for a keyless system.

    if you take it out, check inside the female socket if all the pins are at the same height. And no metal showing up on the side of wires.

    Sometimes simple reinserting fixing issues. If it still does not work I can ship a replacement.

  • @mx5things  Disconnecting battery and reprogramming changed nothing.  Fobs still not recognized/low battery warning.  Will try some more batteries, but I'm not optimistic.  

    What would the next troubleshooting steps be? 

    Would I start removing parts and, if so, which ones?

  • @David N it is not related to batteries, see post above

  • @mx5things Which component am I checking/reconnecting?

    Key-fob control cable in door



    Roof controller?

  • @David N ACC/IG module

  • @mx5things I was afraid you were going to say that.  

  • (TLDR - It works now, but it's a bit flakey)

    Update - I unplugged the ACC/IG module and put back to factory.  Key fob worked as expected.

    I put the module back in place and left it loose/hanging.  Tested the key fob and the various programming options - all work as expected now. 

    After confirming everything works, I zip-tied it to another wiring harness to keep it from flopping around.  Key fob was back to not working.  Undid the zip tie and let if flop down and the key fob works again.

    So - I'm not sure if I should get this module replaced or not - might be a good idea if it's that sensitive to movement.

    @mx5things  What do you recommend?


  • @David N please send an email to with your order number.

Please login to reply this topic!